• IPv6 Präfix-Länge bei HomeSpot

    Hallo, ich habe einen HomeSpot Zugang mit dem kleinen Alcatel Router. Der weißt dahinter liegenden Clients auch IPv6 Adressen zu, allerdings aus einem /64er Netz. Ich würde bei IPv6 eigentlich mehr als ein einzelnes IPv6-Netz erwarten, üblicherweise ein /48er oder /56er Netz. Aber auf einem hinter der Alcatel-Box hängenden Router scheint da nichts weiter anzukommen (Keine 2xxx: Adresse auf dem LAN Interface). Meine Frage ist nun, ob Congstar tatsächlich nur ein /64 Netz zuweist, oder ob das Problem eher an meinem eigenen Router liegt?
  • Hilfreichste Antwort:

  • mbuette schrieb:

    Also der Router hat zwar ein Congstar Logo, aber die Oberfläche ist normal Alcatel?

    Der Router ist ziemlich unverändert, bis auf das congstar Logo, ja. Besonders ausgefeilt ist die Technik des Minirouters auch nicht, dafür war er aber immer zum sehr kleinen Preis zu haben und hat sicherlich schon dem ein oder anderen gute Dienste geleistet.

    Berichte gerne weiter, ob sich das Problem in Zukunft mit einem anderen Router löst. Das interessiert vielleicht noch mehr Nutzer mit einem Interesse an IPv6 :)
  • Alle Antworten:

  • Dark Horse

    Hallo mbuette,

    ich habe offen gestanden nicht ein Wort verstanden von dem was Du schreibst,
    aber vielleicht kann ich ja den nachfolgenden Lesern einige Fragen abnehmen,
    die zur Problemlösung sachdienlich sein könnten.

    Mit dem Mini-Router meinst Du wahrscheinlich den Mini-Router MW40, oder?

    Hierzu sei vorab erwähnt, dass dieser Router ein wenig (Pardon) kastriert ist, da
    Telekom-Branding.

    Es sei denn, Deinen Router hast Du auf dem freien Markt gekauft!
    Dann verzeihe mir bitte meine Nachfrage.

    Schönen Abend noch :)
  • Der Router ist ein MW40(V) mit Software Version MW40_LI_02.00_03.

    Und die IPv6 Geschichten sind noch unüblich, aber prinzipiell habe ich einen Router hinter dem HomeSpot mit mehreren internen Netzen.
    Jedes Netzwerk bekommt bei IPv6 ein /64er Netz. Zum Vergleich: Die normale "Netzmaske" 255.255.255.0 bei IPv4 ist ein /24er Netz mit 24 bit für das Netzwerk (255.255.255, die sind vorgegeben) und 8 bit für die Hosts (die .0 am Ende, also 2^8=256 Hosts pro Netz, die kann ich frei wählen). Das gibt zusammen die 32 bit für eine IPv4 Adresse.

    Bei IPv6 habe ich 128 bit für die Adresse. Die besteht aus 64 bit für das Netzwerk und 64 bit für den Host. Aber da IPv6 Adressen reichlich vorhanden sind, bekommt der Kunde normalerweise nicht nur ein Netzwerk zugewiesen. Das wäre dann ein /64er "Präfix". Stattdessen sollte man ein /48er "Präfix" bekommen.

    Dass heißt also, jeder kann zu hause mehrere Netze vergeben: Jedes Netzwerk hat 64 bit und bei einem 48 bit "Präfix" hat man dann also die Möglichkeit (64-48)=16 bit für die individuellen Netze zu vergeben. Im Endeffekt hat man also 2^16=65536 Netze, die man frei vergeben kann. Und jedes Netz kann bis zu 2^64 =~ 18 Trilliarden(!!!) Hosts beinhalten.

    Aber dann kommt die Marketing-Abteilung und möchte "Alleinstellungsmerkmale" für Firmen-Zugänge haben. Deshalb vergeben viele Provider nur weniger Netze an die Privatkunden. Die bekommen dann häufig nur ein /56er Präfix (also 64-56=8 bit für ihre Netze, das entspricht dann "nur" 256 IPv6 Netzen), so ist das z.B. bei 1&1 VDSL.

    Und bei mir sieht es momentan so aus, als würde Congstar tatsächlich nur ein einzelnes /64er Netz an mich vergeben. Oder mein hinter dem HomeSpot liegender Router und sein Admin macht Mist :) Oder der Mini-Router ist extrem kastriert und unterstützt das sogenannte DHCPv6-PD (Wow: Dynamic Host Configuration Protocol Version 6 - Prefix Discovery) Verfahren nicht, gibt also ein eventuell vorhandenes, großes IPv6 Netzwerk nicht nach "innen" weiter.

    Wie man merkt, ist das alles ziemlich kompliziert. Und weder Congstar noch der Mini-Router sind besonders gut dokumentiert. Deshalb dachte ich mir: "Frag' doch mal jemanden, der sich mit so was auskennt" :)
  • mbuette schrieb:

    Und weder Congstar noch der Mini-Router sind besonders gut dokumentiert.

    Um ehrlich zu sein gibt unsere Dokumentation zu deiner Fragestellung in der Tat nichts her.

    Ich kenne deine genaue Konfiguration nicht, aber hast du die Möglichkeit statt dem Mini-Router ein anderes Gerät zu testen? Sei es ein anderer LTE-Router oder ein Handy (das ja via Tethering auch seinen Internetzugang teilen kann). Dann merken wir vielleicht schon daran, ob dir im Homespot Tarif nur ein kleines Teilnetz zugewiesen wird und es netzseitig ist, oder ob der Minirouter die Schwierigkeiten macht.

    Gruß Max
  • Danke für die zügige Antwort! Aber dummerweise sind Internet und Handy gerade recht essentiell und ich möchte ungern mein komplettes Netz umbauen. Und einen "erwachsenen" LTE Router hatte ich Ende Februar bestellt. Aber dummerweise kommt der aus China und da werde ich wohl warten müssen, bis die globale Wirtschaft wieder rebootet...
  • Dark Horse

    Hallo mbuette,

    zunächst einmal Danke für Deine ausführliche Erklärung, aber wenn ich schreibe,
    dass ich nicht viel verstanden habe, so hast Du keinen Fehler gemacht!
    Ich habe zurzeit noch keinerlei Erfahrung mit IPV6, aber auch kein Problem
    damit, dies zuzugeben! ;)

    Deiner Beschreibung nach ist auf Deinem Router eine Telekom-Firmware,
    die diverse (auch sicherheitsrelevante Funktionen/Optionen) nicht zulässt.

    Dir bliebe letzten Endes (um sicher zu gehen) nur noch die Alternative, es
    mit einem anderen LTE-Router auszuprobieren.

    Ich gehe davon aus, dass Du das standardmäßig im Hause rumliegen hast! :D

    Just kidding...

    Vielleicht kann Dir jemand aus Deinem Freundeskreis aushelfen?!

    Schönen Tag noch :)
  • Also der Router hat zwar ein Congstar Logo, aber die Oberfläche ist normal Alcatel? Und wie oben schon geschrieben hatte ich ja schon einen neuen Router bestellt, bevor die Welt ein "shutdown now" ausgeführt hat :(
    Aber ich denke auch, dass der Mini-Router das Problem ist. IPv6 ist aber auch nicht wirklich kritisch, deswegen warten bis die Welt aus Ihrem Corona-Koma erwacht und was professionelles dranklemmen...
  • mbuette schrieb:

    Also der Router hat zwar ein Congstar Logo, aber die Oberfläche ist normal Alcatel?

    Der Router ist ziemlich unverändert, bis auf das congstar Logo, ja. Besonders ausgefeilt ist die Technik des Minirouters auch nicht, dafür war er aber immer zum sehr kleinen Preis zu haben und hat sicherlich schon dem ein oder anderen gute Dienste geleistet.

    Berichte gerne weiter, ob sich das Problem in Zukunft mit einem anderen Router löst. Das interessiert vielleicht noch mehr Nutzer mit einem Interesse an IPv6 :)
  • Genau, ich war bei LTE anfänglich sehr skeptisch: auf dem Handy nutze ich das primär beim pendeln in Zügen oder U-Bahnen und das ist, nun ja, verbesserungswürdig ;) Deshalb flex-Tarif und günstigen Router zum testen bestellt. Und wenn die Welt wieder aufwacht und mein richtiger Router kommt, habe ich ein Backup.
    Und ich habe ein Bookmark auf das Thema angelegt, werde berichten wie's weitergeht...
  • mbuette schrieb:

    Und ich habe ein Bookmark auf das Thema angelegt, werde berichten wie's weitergeht...
    Hey mbuette, gibt es schon was neues- hoffentlich erfreuliches?

    MFG
    Mario J.
    Muss man wissen:
    AGB & Preise / Lieferzeit & Versand / Rufnummernmitnahme / Handykonfiguration (Internet & MMS) / Optionsbuchungen Prepaid / Optionsbuchungen Postpaid / Tarifwechsel / Mobilfunknutzung im Ausland / Alles rund um DSL - Einrichtung & Co
    Wenn es um deinen Vertrag oder um deine Kundendaten geht, brauche ich ein paar Daten um einen Blick in dein Kundenkonto werfen zu dürfen!
  • OK, bin doch noch da und habe jetzt versucht, alle Präfixe von /48 bis /63 anzufordern. Leider ohne Erfolg, ich bekomme immer ein einzelnes /64er Netz :( Zum Vergleich, V* macht das genau so und O* bietet überhaupt kein IPv6.
    Allerdings ist mein V* Zugang auch ein prepaid Datentarif zum testen und da ist das auch OK: an einen mobile Hotspot wird man kaum komplexe Netzwerktopologien anbinden. Der congstar HomeSpot wird aber als DSL Ersatz vermarktet und mein letzter DSL Anbieter hat zumindest ein /56er Netz (=256 interne IPv6 Netze) angeboten.
    Das ist zum einen schade, zum anderen aber auch unverständlich: das tolle an IPv6 ist doch gerade, dass Adressknappheit kein Thema mehr sein sollte....
  • mbuette schrieb:

    Der congstar HomeSpot wird aber als DSL Ersatz vermarktet und mein letzter DSL Anbieter hat zumindest ein /56er Netz (=256 interne IPv6 Netze) angeboten.

    Welche APN Daten hast du im Router hinterlegt?

    Normal sollte es in etwa so aussehen:

    Access Point Name (APN): internet.t-mobile
    Zugangsnummer: *99#
    Benutzername: tm
    Benutzerpasswort: tm

    Als Alternative (die wir derzeit vor allem empfehlen, wenn jemand mit einer Playstation/Xbox den Homespot nutzen und online spielen möchte) gibt es noch den folgenden Zugang:

    Access Point Name (APN): internet.t-d1.de
    Telephone Number / Zugangsnummer: *99#
    Benutzername: internet
    Benutzerpasswort: t-d1

    Damit wird eine öffentliche IPv4 Adresse vergeben - ich kann mir vorstellen, dass die Zuweisung von IPv6 Subnetzen da auch anders gelöst sein könnte. Vielleicht ist das einen Versuch wert.
  • Max S. schrieb:

    Access Point Name (APN): internet.t-mobile
    Ja, das habe ich konfiguriert, habe ich von dem Alcatel übernommen. Wobei die anderen Daten nicht notwendig zu sein scheinen? Bei mir hat es nur mit dem APN funktioniert...

    Aber ich werde die alternative Konfiguration gerne testen, allerdings erst nächstes Wochenende: Business-critical und so. Und mein neuer Router ist ein bisschen frickelig: Zum Tausch der SIM muss ich: Antennen abschrauben, Gehäuse öffnen und dann das Mainboard lösen. Warnung vor dem ZBT WG-3526 :) Aber dafür mit 120€ für einen OpenWrt-LTE Router unschlagbar günstig...

    Und ich bin beeindruckt, dass congstar öffentliche IPv4 Adressen einfach so vergibt. Besagter Flatrate Provider nimmt dafür einmalig 50€...
  • mbuette schrieb:

    Max S. schrieb:

    Access Point Name (APN): internet.t-mobile
    Ja, das habe ich konfiguriert, habe ich von dem Alcatel übernommen. Wobei die anderen Daten nicht notwendig zu sein scheinen? Bei mir hat es nur mit dem APN funktioniert...
    Aber ich werde die alternative Konfiguration gerne testen, allerdings erst nächstes Wochenende: Business-critical und so. Und mein neuer Router ist ein bisschen frickelig: Zum Tausch der SIM muss ich: Antennen abschrauben, Gehäuse öffnen und dann das Mainboard lösen. Warnung vor dem ZBT WG-3526 :) Aber dafür mit 120€ für einen OpenWrt-LTE Router unschlagbar günstig...

    Und ich bin beeindruckt, dass congstar öffentliche IPv4 Adressen einfach so vergibt. Besagter Flatrate Provider nimmt dafür einmalig 50€...
    Hallo,

    hattest du vielleicht erfolg? Ich habe auch versucht einen präfix 56 bzw. präfix 60 zu bekommen, habe aber gescheitert.

    Ich habe mir einen GL-X750 geholt und OpenWrt neu installiert. Mit der APN Einstellung die man auf der webseite oder forum sehen konnte habe ich eine ipv6/128 und ipv6-pd/64 gesehen. Ich verstehe ehrlich gesagt nicht was dhcp-pd bzw. ipv6-pd ist, aber eine globale ip scheint mein gerät zu sehen.

    Auf der test-ipv6.com sehe ich meine globale ip adresse (2a01:***) und ich kann bestätigen dass das meine ip adresse vom laptop ist und nicht vom router. Aber von aussen scheint meine adresse nicht erreichbar zu sein, obwohl ich das port 8080 freigeschalten habe. Aber auf der FAQ von Homespot steht aber auch dass congstar über offentliche ip-adresse nicht erreichbar ist. Naja, aber eine globale ipv6 zu haben aber trotzdem von aussen nicht erreichbar zu sein, kann ich nicht ganz verstehen.. aber man muss wohl nicht alles verstehen.

    Ich wollte einen ipv6 subnetz haben weil ich neulich mit openthread border router experimentiere und dieses border router braucht einen subnet. Nun ist aber die frage ob man auch ohne subnetz mit DHCPv6-PD globale ips vergeben kann. Anscheinend schon? Ich weiss es nicht. Zumindest sieht es so aus. Vielleicht? Vielleicht auch nicht.
  • Die /128 ist die einzelne IPv6 Adresse auf der externen, LTE Schnittstelle. Das PD steht für "Prefix Delegation" und ist wie bei mir ein einzelnes /64 Netz, die Standard-Größe von IPv6 Netzen. Das reicht dann für ein einzelnes Netzwerk. Sobald da irgendwo ein Router steht ist dahinter kein IPv6 mehr verfügbar. Es gibt ein reserviertes, offizielles IPv6 Netz für Beispiele in Anleitungen / Dokumentationen. Das ist 2001:db8::/32 und ist per RFC3849 reserviert. Das "sieht aus" wie ein öffentliches Netzwerk, aber weil es reserviert ist, gibt es keine Adresskonflikte mit dem Internet. Vielleicht akzeptiert dein Router das als "öffentlichen Präfix"?

    Ich persönlich habe aufgegeben und hole mir ein /48er Netz von tunnelbroker.net.