• Telekom Speedstick V E3372 funktioniert nicht mit wvdial

      Ich habe einen Telekom Speedstick V (Huawei E3372) mit einer Congstar Sim bestückt und die folgenden Parameter in der wvdial.conf eingetragen:
      [Dialer congstar]
      Auto DNS = on
      Init1 = ATZ
      Init2 = ATQ0 V1 E1 S0=0
      Init3 = AT+CGDCONT=1,"IP","internet.t-mobile"
      ISDN = 0
      Stupid Mode = off
      Phone = *99#
      Modem = /dev/ttyUSB1
      Username = t-mobile
      Password = tm
      Baud = 9600


      Die Verbindung wird aber abgebrochen mit den Meldungen:
      --> WvDial: Internet dialer version 1.61
      --> Initializing modem.
      --> Sending: ATZ
      OK
      --> Sending: ATQ0 V1 E1 S0=0
      OK
      --> Sending: AT+CGDCONT=1,"IP","internet.t-mobile"
      AT+CGDCONT=1,"IP","internet.t-mobile"
      OK
      --> Modem initialized.
      --> Sending: ATDT*99#
      --> Waiting for carrier.
      ATDT*99#
      CONNECT
      --> Carrier detected. Waiting for prompt.
      --> Connected, but carrier signal lost! Retrying...
      --> Sending: ATDT*99#
      --> Waiting for carrier.
      --> Timed out while dialing. Trying again.
      --> Sending: ATDT*99#
      --> Waiting for carrier.
      --> Timed out while dialing. Trying again.
      --> Sending: ATDT*99#
      --> Waiting for carrier.
      --> Timed out while dialing. Trying again.


      Wie lauten die richtigen Parameter ?
    • Hilfreichste Antwort:

    • Das Problem ist nun gelöst und nachfolgend ist die Lösung beschrieben.

      Der Surfstick Huawei E3372h (Telekom Speedstick LTE V) muss zwingend im Linuxprogramm wvdial auf dem zweiten USB-Port angesprochen werden (Modem = /dev/ttyUSB*) . Auf dem ersten Port reagiert der Stick ebenfalls, aber nicht richtig.

      Der richtige Port kann mit dem Kommando dmesg|grep GSM ermittelt werden.


      [ 20.490777] usbserial: USB Serial support registered for GSM modem (1-port)
      [ 20.490952] option 1-1.4:1.0: GSM modem (1-port) converter detected
      [ 20.492286] usb 1-1.4: GSM modem (1-port) converter now attached to ttyUSB1
      [ 20.492786] option 1-1.4:1.1: GSM modem (1-port) converter detected
      [ 20.493026] usb 1-1.4: GSM modem (1-port) converter now attached to ttyUSB2 <-- ist der richtige

      In der Datei /etc/wvdial.conf ist folgender Eintrag einzufügen:

      [Dialer congstar]
      Carrier Check = no
      Init3 = AT+CPIN=**** # Sim Card PIN
      Init4 = AT+CGDCONT=1,"IP","internet.t-mobile"
      Modem = /dev/ttyUSB2
      Stupid Mode = 1
      Phone = *99#
      Dialer Command = ATD
      Dial Attemps = 2
      Username = tm
      Password = tm

      Achtung! die PIN wurde im Smartphone inaktiviert (Zeile Init3 entfernen), sollte die PIN aktiv sein ist der
      Zeile Init3 **** mit der PIN zu ersetzen.

      Gestartet wird die Netzwerkverbindung dann mit dem Kommando sudo wvdial congstar

      Ich hoffe es hilft anderen, ich habe lange genug gesucht.
    • Alle Antworten:

    • Guten Morgen franze_m,

      die APN-Einstellungen für unsere UMTS Sticks lauten wie folgt:

      APN (auch Zugangspunkt genannt): statisch
      APN-Name: internet.t-mobile
      Zugangsnummer: *99#
      Benutzername: tm
      Benutzerpasswort: tm
      IP-Einstellung: dynamisch
      WINS-Einstellungen: dynamisch
      DNS-Einstellung: dynamisch
      Auth.protokoll-Einstellung: CHAP

      Weitere Informationen findest du auch hier.

      Viele Grüße
      Jonathan
      Um euch schnell & unkompliziert helfen zu können empfiehlt sich die Hinterlegung eurer Kundendaten (vollständiger Name, Rufnummer und Vertrags- oder Kundennummer) im Benutzerprofil. Weitere Informationen dazu findet ihr hier.
    • Leider hilft mir die Antwort nicht weiter, da ich kein Windows sonder ein Raspberry mit Linux betreibe.


      Die Angaben auf Ihrer Seite habe ich ebenfalls gefunden, lassen sich aber nicht identisch in die Konfiguration umsetzen.
      Ich habe schon Tage mit diesem Stick verbracht und herausgefunden, das an meinem Standort, z.B. Das Vodafonenetz nicht innerhalb des Hauses verfügbar ist, obwohl es auf der Netzabdeckung als verfügbar deklariert wurde und der Stick incl. Raspberry z.b. in Heilbronn funktionierte.
      Ich habe daraufhin die Simkarte mit der Congstar-Karte ersetzt, da ich mit meinem Smartphone über Magenta immer einen guten Empfang habe.
      Nun kämpfe ich mit den Parametern. Es muss doch in der grossen Telekom oder bei Congstar jemanden geben, der sich mit dem Standard-Betriebssystem Linux auskennt, in ihrem Rechenzentrum laufen tausende von Linuxrechnern.

      Ich benötige die genauen Parameter in der Datei /etc/wvdial.conf, meine Einstellung habe ich Ihnen unten mitgeteilt, ebenso wie die Fehlermeldungen. Sollten noch Einstellungen in weiteren Dateien notwendig sein, bitte ich Sie mir dies mitzuteilen.




      /etc/wvdial.conf

      [Dialer congstar]
      Auto DNS = on
      Init1 = ATZ
      Init2 = ATQ0 V1 E1 S0=0
      Init3 = AT+CGDCONT=1,"IP","internet.t-mobile"
      ISDN = 0
      Stupid Mode = off
      Phone = *99#
      Modem = /dev/ttyUSB1
      Username = tm
      Password = tm
      Baud = 9600





      --> WvDial: Internet dialer version 1.61
      --> Initializing modem.
      --> Sending: ATZ
      OK
      --> Sending: ATQ0 V1 E1 S0=0
      OK
      --> Sending: AT+CGDCONT=1,"IP","internet.t-mobile"
      AT^CU
      OK
      R
      --> Modem initialized.
      --> Sending: ATDT*99#
      --> Waiting for carrier.
      CATDT*99#
      COMMAND NOT SUPPORT
      =0
      AT^CURC=0
      OK
      AT^CURC=0
      OK
      ~ xp~
      --> Timed out while dialing. Trying again.
      --> Sending: ATDT*99#
      --> Waiting for carrier.
      ATDT*99#
      CONNECT
      --> Carrier detected. Waiting for prompt.
      --> Connected, but carrier signal lost! Retrying...
      --> Sending: ATDT*99#
      --> Waiting for carrier.
      --> Timed out while dialing. Trying again.


      Mit freundlichen Grüssen
      Franze_m
    • Hey franze_m,

      da es sich um Fremdhardware handelt, kann ich da keine fundierteren Informationen geben als mein Kollege. Vielleicht hat jemand anderes hier im Forum ja noch eine Idee?

      MFG
      Mario J.
      Muss man wissen:
      AGB & Preise / Lieferzeit & Versand / Rufnummernmitnahme / Handykonfiguration (Internet & MMS) / Optionsbuchungen Prepaid / Optionsbuchungen Postpaid / Tarifwechsel / Mobilfunknutzung im Ausland / Alles rund um DSL - Einrichtung & Co
      Wenn es um deinen Vertrag oder um deine Kundendaten geht, brauche ich ein paar Daten um einen Blick in dein Kundenkonto werfen zu dürfen!
    • Hallo franze_m

      Die PIN-Abfrage der SIM ist abgestellt?

      Im Log sehe ich:

      franze_m schrieb:

      CATDT*99#
      COMMAND NOT SUPPORT
      Aber in der wvdial.conf ist dieser Aufruf doch gar nicht drin!?
      Hast du auch oben die reale wvdial.conf gepostet?


      CATDT gibt es nicht, soviel ich weiß.


      _____________


      Versuche doch mal diese wvdial.conf:



      Quellcode

      1. [Dialer Defaults]
      2. Init2 = ATQ0 V1 E1 S0=0
      3. Modem Type = Analog Modem
      4. ISDN = 0
      5. Init1 = ATZ
      6. Modem = /dev/ttyUSB1
      7. Baud = 921600
      8. [Dialer congstar]
      9. Carrier Check = no
      10. Init3 = AT+CPIN=**** # Sim Card PIN
      11. Init4 = AT+CGDCONT=1,"IP","internet.t-mobile"
      12. Stupid Mode = 1
      13. Phone = *99#
      14. Dialer Command = ATD
      15. Dial Attemps = 2
      16. Username = tm
      17. Password = tm
      Alles anzeigen
      Bei "Sim Card PIN" kommt natürlich die PIN hin, wenn Abfrage nicht abgeschaltet.
    • Hallo Max,
      ich habe deine Config ausprobiert und die PIN-Zeile als Kommentar gesetzt, da ich die PIN ausgeschaltet habe.

      Das Ergebniss war nicht erfolgreich, ich erhalte die folgenden Meldungen:
      --> WvDial: Internet dialer version 1.61
      --> Initializing modem.
      --> Sending: ATZ
      OK
      --> Sending: ATQ0 V1 E1 S0=0
      OK
      =
      --> Sending: AT+CGDCONT=1,"IP","internet.t-mobile"
      0AT+CGDCONT=1,"IP","internet.t-mobile"
      OK
      --> Modem initialized.
      --> Sending: ATDT*99#
      --> Waiting for carrier.
      ATDT*99#
      CONNECT
      --> Carrier detected. Starting PPP immediately.
      --> Starting pppd at Sat May 23 16:36:31 2020
      --> Pid of pppd: 2408
      --> Using interface ppp0
      --> pppd: ���[01]���[01]
      --> pppd: ���[01]���[01]
      --> pppd: ���[01]���[01]
      --> pppd: ���[01]���[01]
      --> pppd: ���[01]���[01]
      --> Disconnecting at Sat May 23 16:37:01 2020
      --> The PPP daemon has died: A modem hung up the phone (exit code = 16)
      --> man pppd explains pppd error codes in more detail.
      --> Try again and look into /var/log/messages and the wvdial and pppd man pages for more information.
      --> Auto Reconnect will be attempted in 5 seconds
      --> Initializing modem.
      --> Sending: ATZ
      --> Sending: ATQ0
      --> Re-Sending: ATZ
      ^CCaught signal 2: Attempting to exit gracefully...
      --> Modem not responding.
      --> Disconnecting at Sat May 23 16:37:08 2020

      tail /var/log/messages
      May 23 16:36:31 raspberrypi4b pppd[2408]: pppd 2.4.7 started by root, uid 0
      May 23 16:36:31 raspberrypi4b pppd[2408]: Using interface ppp0
      May 23 16:36:31 raspberrypi4b pppd[2408]: Connect: ppp0 <--> /dev/ttyUSB1
      May 23 16:37:01 raspberrypi4b pppd[2408]: LCP: timeout sending Config-Requests
      May 23 16:37:01 raspberrypi4b pppd[2408]: Connection terminated.
      May 23 16:37:01 raspberrypi4b pppd[2408]: Modem hangup
      May 23 16:37:01 raspberrypi4b pppd[2408]: Exit.

      Wenn ich den Linux Networkmanager verwende kann ich eine Verbindung aufbauen, ich möchte aber den Raspberry ohne GUI laufen lassen, daher benötige ich das Programm wvdial.

      Viele Grüsse
      Franze_M
    • franze_m schrieb:

      May 23 16:36:31 raspberrypi4b pppd[2408]: Connect: ppp0 <--> /dev/ttyUSB1
      May 23 16:37:01 raspberrypi4b pppd[2408]: LCP: timeout sending Config-Requests
      2 Dinge würde ich noch versuchen:

      1. Ist der User der wvdial startet, überhaupt dazu berechtigt /dev/ttyUSB1 anzusprechen?
      Danach sieht es mir nicht aus.
      Bei meiner Distribution muss der User in der Gruppe "dialout" sein. Wie das bei deiner geregelt ist, weiß ich nicht.

      2. Probiere mal USB0 statt USB1 - einfach mal probieren, bestimmt bringt es nichts, aber wer weiß

      Wenn beides nicht hilft, würde ich dir raten in einer entsprechenden Raspi- oder einer anderen passenden Linux-Gruppe nachzufragen.
      Dort kann man dann besser auf deine Konfiguration eingehen.
      Hier führt das deutlich zu weit.

      Du hast kein Problem mit Congstar!

      Dein Problem liegt alleine in deiner Konfiguration.
    • Ich schon wieder! ;)

      Hast du mal nach den Rechten geschaut?

      Es ist schon viele Jahre her, dass ich Netzwerkverbindungen über den pppd aufgebaut habe.
      Das geht heute einfacher.

      Aber ich kann mich erinnern, dass der pppd mit rootrechten aufgerufen werden muss!


      franze_m schrieb:

      Wenn ich den Linux Networkmanager verwende kann ich eine Verbindung aufbauen....
      Eben.
      Heute geht es einfacher. Ich benutze auch den Netzwerkmanager. Und zwar ausschließlich.
      Der kann schon einiges, nicht nur einen LTE-Stick verwalten. Warum bleibst du nicht bei dem und vergißt wvdial?


      franze_m schrieb:

      ich möchte aber den Raspberry ohne GUI laufen lassen, daher benötige ich das Programm wvdial.

      Nö.
      Den Netzwerkmanager gibt es doch auch ohne GUI.
      Der läuft hervorragend in der Konsole.

      Bei mir habe ich solch nette Progrämmchen wie nmtui-edit, nmtui, nm-cli, nm-online.......

      Falls du den Netzwerkmanager bereits mit GUI eingerichtet/konfiguriert hattest, ist er vielleicht schon voll lauffähig.

      Versuche doch mal im Terminal/auf einer Konsole

      Quellcode

      1. nm-online
      Vielleicht bist du schneller online als du denkst! ;)


      PS: Ich kenne deine Distribution nicht. Die Konsolenversion kann bei dir etwas anders heißen! Auf jeden Fall läuft der Netzwerkmanager auch ohne GUI.
    • Dark Horse

      Hallo franze_m,

      ergänzend zu ohneLTE möchte ich vorschlagen, wenn es denn unbedingt
      mit wvdial funken soll oder muss, einfach mal su vor wvdial (plus Parameter)
      einzufügen.

      Ist natürlich nicht dienlich, wenn man mit einem BashScript automatisiert
      oder cronjob arbeiten möchte.
      Sollte es nun aber funken, dann weißt Du, dass Du entsprechende Rechte
      zuteilen musst.

      Ist schon länger her, meine Linux-Kenntnisse, von daher solltest Du tatsächlich
      ein Linuxforum nach Deinem Gusto suchen, denn die Thematik ist für das Forum
      hier doch ein wenig overdosed.

      Schönen Tag noch :)

      Edit: P.S.: Sollte es mit wvdial jetzt immer noch nicht gehen, dann stimmt irgend
      ein Wert eines Parameters nicht oder er fehlt gänzlich und wird aber gebraucht!
    • Dark Horse schrieb:

      einfach mal su vor wvdial (plus Parameter)
      einzufügen.
      Was du meinst ist sudo.
      Den Befehl "su" gibt es auch, er dient aber für etwas anderes.

      Dark Horse schrieb:

      Ist natürlich nicht dienlich
      Das stimmt. Es funktioniert auch nicht.
      Auch nicht in Scripten und Cronjobs. :)
      Deine Linux-Kenntnisse sind nicht nur lange her, sie sind auch nicht sehr tiefgreifend.

      Dark Horse schrieb:

      ... dann stimmt irgend ein Wert eines Parameters nicht oder er fehlt gänzlich und wird aber gebraucht
      :thumbsup:
      Das stimmt natürlich fast immer!
      Und seltsamerweise funktionieren viele Dinge, sobald man es richtig macht. :D
    • Dark Horse

      ohneLTE schrieb:

      Was du meinst ist sudo.
      Asche auf mein Haupt! ;)
      Wie gesagt, meine Linuxkenntnisse sind stark angerostet!
      Ich hatte zuletzt damit zu tun, da gab es noch WinModems...
      Aus heutiger Sicht Steinzeit!


      ohneLTE schrieb:

      Deine Linux-Kenntnisse sind nicht nur lange her, sie sind auch nicht sehr tiefgreifend.

      Er soll es ja nur testweise einmal probieren, um den Fehler
      einzugrenzen, denn aus meiner Sicht...


      ohneLTE schrieb:

      Und seltsamerweise funktionieren viele Dinge, sobald man es richtig macht.

      ... ist es nicht sachdienlich, die Fehlerquelle anhand von Logs
      bzw. Fehlermeldungen zu suchen, es sei denn, man hat die
      Erfahrung, was zu welchem Fehler führt!
      Wenn bei mir etwas nicht funktioniert, gehe ich von einem
      Pebcak-Problem aus und in der Regel stimmt das auch so.

      Zu vergleicehn mit Korrektuerlesen:
      Übersiehst Du einen Tippfehler beim ersten Mal, übersiehst Du
      ihn auch ein zweites und drittes Mal! ;)
      Das war des Pudels Kern meiner Aussage...
      Auch Dir schönen Abend noch :)
    • Das Problem ist nun gelöst und nachfolgend ist die Lösung beschrieben.

      Der Surfstick Huawei E3372h (Telekom Speedstick LTE V) muss zwingend im Linuxprogramm wvdial auf dem zweiten USB-Port angesprochen werden (Modem = /dev/ttyUSB*) . Auf dem ersten Port reagiert der Stick ebenfalls, aber nicht richtig.

      Der richtige Port kann mit dem Kommando dmesg|grep GSM ermittelt werden.


      [ 20.490777] usbserial: USB Serial support registered for GSM modem (1-port)
      [ 20.490952] option 1-1.4:1.0: GSM modem (1-port) converter detected
      [ 20.492286] usb 1-1.4: GSM modem (1-port) converter now attached to ttyUSB1
      [ 20.492786] option 1-1.4:1.1: GSM modem (1-port) converter detected
      [ 20.493026] usb 1-1.4: GSM modem (1-port) converter now attached to ttyUSB2 <-- ist der richtige

      In der Datei /etc/wvdial.conf ist folgender Eintrag einzufügen:

      [Dialer congstar]
      Carrier Check = no
      Init3 = AT+CPIN=**** # Sim Card PIN
      Init4 = AT+CGDCONT=1,"IP","internet.t-mobile"
      Modem = /dev/ttyUSB2
      Stupid Mode = 1
      Phone = *99#
      Dialer Command = ATD
      Dial Attemps = 2
      Username = tm
      Password = tm

      Achtung! die PIN wurde im Smartphone inaktiviert (Zeile Init3 entfernen), sollte die PIN aktiv sein ist der
      Zeile Init3 **** mit der PIN zu ersetzen.

      Gestartet wird die Netzwerkverbindung dann mit dem Kommando sudo wvdial congstar

      Ich hoffe es hilft anderen, ich habe lange genug gesucht.